Search | Statistics | User Listing Forums


Forums supporting
reViSiT (http://revisit.info)
and MIVI (http://mivi.nashnet.co.uk)
nashNET Forums ->  reViSiT - Tracking Software for VST hosts -> Help & Support -> View Thread

You are logged in as a guest. ( logon | register )

cubase sx3 steals keyboard input from revisit
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   reViSiT - Tracking Software for VST hosts -> Help & SupportMessage format
 
fegi
Posted 2006-10-24 7:30 PM (#13301)
Subject: cubase sx3 steals keyboard input from revisit



Veteran

Posts: 102
100
Location: Austria
hi!

i updated to cubase sx3 recently and now i have the problem that cubase steals all the key inputs from revisit (even in manual mode). only when i set cubase's keyboard shortcuts to "clear all" i can use revisit's shortcuts like alt-o etc. i didn't have this behaviour in sx2.

is this a known issue?

greetings,

fegi
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2006-10-25 5:55 PM (#13302 - in reply to #13301)
Subject: cubase sx3 steals keyboard input from revisit



Developer

Posts: 746
50010010025
Location: England

Hi Fegi,

SX2 to SX3 shouldn't present too much of a problem - unless they've changed something in one of the recent patches. reViSiT is actually tested on SX3, so it should work. Just ensure you select reViSiT's Pattern Window (not the toolbar) before you start typing in keyboard commands.

There's also an option in Cubase preferences "Plugins receive keyboard commands" (or similar), which you might try playing with. However, it really shouldn't make any difference.

It does seem strange the Manual Mode isn't helping. What Version and Build of Cubase are you using (Help -> About)?

All the best,
Chris


Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2006-11-01 7:42 PM (#13303 - in reply to #13302)
Subject: cubase sx3 steals keyboard input from revisit



Veteran

Posts: 102
100
Location: Austria
hi again!

i use cubase sx 3.1.1 build 944.

i played around with the settings today and made the following observations:

under preferences i checked "plugins receive keyboard commands" and left cubase's keyboard mapping to "default". with this setting cubase steals all the keyboard input from revisit.

so i activated manual key mode...

now revisit gets the "alt-o" input, but unfortunately cubase receives the command as well. what's strange is, that cubase doesn't receive "alt-i" (show inspector) any more. so cubase's behaviour is different depending which keyboard shortcut you use.

i also noticed a small bug: when you close the revisit vsti window with manual key mode switched on and then reopen revisit's window, one can't close the help popup with escape unless you switch manual key mode off.

i hope my explanations where understandable

greetings,

fegi
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2006-11-01 9:25 PM (#13304 - in reply to #13303)
Subject: cubase sx3 steals keyboard input from revisit



Expert

Posts: 512
500
Location: Netherlands
I'm not sure under what mode my plugins react atm, the last time I checked a lot of stuff seems to have been messed up, so I rather not touch it.

However, some keys don't react when cubase's project window is active, like ALT left rightfor column move -even if the revisit floating window is activated or the pattern editor itself!- when you activate for instance the VSTi list or the CPU meter, then things seem to work fine. The trick is, thus, to activate something else than the project window.. at least here that is..



Musictechnology-bachelor degree in Composing, Producing, Sounddesign, Software - composer for film/tv/theatre/games/commercials - imdb registered - IT2 guru - MSX guru - sounddesign guru
Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2006-11-02 8:21 PM (#13305 - in reply to #13304)
Subject: cubase sx3 steals keyboard input from revisit



Veteran

Posts: 102
100
Location: Austria
ahhh...that helped when i minimize the project window, revisit gets all keyboard input. i don't even have to activate manual key mode any more. thanks for the hint

greetings,

fegi
Bookmark and Share Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)