Search | Statistics | User Listing Forums


Forums supporting
reViSiT (http://revisit.info)
and MIVI (http://mivi.nashnet.co.uk)
nashNET Forums ->  reViSiT - Tracking Software for VST hosts -> Testing & Development -> View Thread

You are logged in as a guest. ( logon | register )

reViSiT v0.94 Std Beta released!
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   reViSiT - Tracking Software for VST hosts -> Testing & DevelopmentMessage format
 
chrisnash
Posted 2008-08-21 7:12 PM (#14335)
Subject: reViSiT v0.94 Std Beta released!



Developer

Posts: 746
50010010025
Location: England

Hi Everyone,

It is my pleasure to deliver reViSiT v0.94. The goal has always been to have a rock-solid reViSiT before the initial “public” release, and the last few months have brought that day tantalizingly close; the roadmap to release has been planned:
   The forthcoming reViSiT 0.95 Std will be the last scheduled beta release to the public.
   The remaining versions, 0.96-0.99, will be internal builds of the Professional Edition, in preparation for its own public release, as part of a scientific research study that will begin at the release of v1.0. At that point, the Professional edition will be free to anyone who takes part in the study (details of which will be announced nearer the time).
   In the meantime, reViSiT v0.94 features many improvements and updates:

  • Resonant Filter Support
    reViSiT now provides you with a resonant low pass filter effect for each instrument. The feature is similar to that of Impulse Tracker, with options to extend the frequency range - 5kHz, 10kHz and 20kHz settings, for compatibility with IT, MPT and the human ear, respectively (defaulting to the format of the loaded file). The filter effect is accessible through a dedicated instrument dual envelope (for cutoff frequency and resonance, respectively) or through the Zxx effect, in the pattern (Z00-Z7F changes cutoff frequency, Z80-Z8F changes resonance). The filters, as part of the program and not a sound driver hack, should behave slightly more intuitively compared to that in IT!

  • Major stability improvements
    The crash report feature, together with some much appreciated support from the Pro testers, has allowed me to plug some holes in reViSiT’s foundations, which were causing various forms of unpleasantness. Although I’ve had relatively few complaints regarding stability, these fixes should be a major improvement, taking reViSiT a giant step closer to the v1.0 release. MIDI timing has also been improved, though some hosts will favour shorter ASIO latencies (e.g. <15ms), when playing detached from the host.

  • Lots of minor additions and improvements
    The book is now closed on new v1.0 features (though the v2.0 feature list is growing steadily), and this release sees the introduction of the last few features, such as: envelope carry (where the envelope of a new note picks up where the last left off); note-less MIDI (MIDI messages can now be sent without triggering a note, using the instrument column on it’s own); an enlarged toolbar (for grabbing and moving the reViSiT window); and fixes for lots of smaller interface and workflow niggles.

  • [ Professional Edition Update ]
    The big news for the Pro edition is the introduction of MIDI-triggered pattern playback, allowing you to play tracker patterns from a keyboard or MIDI track in the host. Recording a MIDI track and linking it to reViSiT thus allows you to lay down, cut up and move around your tracked music with the tools of the host – for example, with the mouse in the arrange window. The feature currently only permits one pattern playing at a time, but reViSiT’s architecture has already been refitted to extend this further down the road...

For full details and many more changes, please read the release notes and download reViSiT v0.94 Beta from http://www.nashnet.co.uk/english/revisit/download.htm.

If anyone has any questions, feel free to pose them on the forum, and I’ll try to answer you as quickly as possible. For more information, see the reViSiT website @ http://revisit.nashnet.co.uk.

Enjoy!

All the best,
Chris

Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-08-25 10:10 AM (#14339 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
Just a small detail, the introduction section in the readme talks about "VSTrack" (along with "reViSiT"), wasn't this the old name, and thus now obsolete? :P
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-08-25 3:13 PM (#14340 - in reply to #14339)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
Oh I think there's something wrong with CTRL-F2 (paste copied pattern layout). Not sure what happens, busy on a tune atm, will check out later. For the moment I think it may not copy patternlengths smaller than the longest one you've ever copied, as my pat-len of 60 is pasted as 84 again (which was once my longest pattern).. but anyway, it may all be gobbledegob, will get back on it. :P
Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2008-08-27 6:24 PM (#14341 - in reply to #14335)
Subject: RE: reViSiT v0.94 Beta released!



Veteran

Posts: 102
100
Location: Austria
hey chris!

unfortunately revisit 0.94 doesn't work with reaper anymore. playback is fine when the host is playing back. but if revisit is playing back on its own, i can only hear random notes (and very few of them)...
i guess it must have something to do with this...

[MOD] New code for MIDI timing when host isn't playing.

i sent the same report on 093 pre 3 via the built in comment system... not sure if you received that message, but i dont have a RVc file left on my hd.

the last version that was working fine for me was 0.93 pre 1, so i have to stick with that version for now.

greetings,

fegi
Bookmark and Share Top of the page Bottom of the page
arnorhs
Posted 2008-08-31 3:29 AM (#14351 - in reply to #14335)
Subject: RE: reViSiT v0.94 Beta released!


Member

Posts: 10

Hi Chris, I hope you've noticed the nasty bug reports I've been sending... Every time I try to change the output bus in the order list (F11) revisit freezes on me.. .. It happens on opened projects, new fresh projects and I can't seem to get around it
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2008-09-01 10:33 PM (#14352 - in reply to #14351)
Subject: RE: reViSiT v0.94 Beta released!



Developer

Posts: 746
50010010025
Location: England
Hi all,

'Have been offline a bit lately due to Internet problems and weddings to go to.

CS_TBL:

That was a typo in the readme, will be fixed in next release. If you can confirm the other problems, I'll certainly take a look - but it does depend on where you paste the pattern from. I'll I have to check the Ctrl-F2 code, but in one of the features; if you paste a 64 row clipboard at row 32, the pattern will be lengthened to 96.

Fegi:

Worrying that the MIDI doesn't work for you in REAPER. Can you check whether *non* "VST Host" (e.g. external) MIDI works in both sync'd or non-sync'd mode?

Arnor:

I'm afraid I haven't been getting any comments or crash reports. I was naively thinking this was because there were no comments or crashes. Naturally, and not without a hint of irony; it was because the crash report system was broken. It is fixed now, so try again and I'll take a peak.

Cheers, everyone!

Chris
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-01 10:57 PM (#14353 - in reply to #14352)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
oh great, I had a crash some week ago, and I thus assumed it had been sent.. :P

(edit: talk about the devil, the bl*dy thing just crashed, hopefully the report does come in now..)

Edited by CS_TBL 2008-09-01 11:18 PM
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2008-09-02 1:14 AM (#14354 - in reply to #14353)
Subject: Re: reViSiT v0.94 Beta released!



Developer

Posts: 746
50010010025
Location: England
CS_TBL:

I have a comment from you (~00:15), but no crash report. Unfortunately, I can't debug the comments. Did you see the crash report dialog?
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-02 9:07 AM (#14355 - in reply to #14354)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
No, maybe because it didn't really was a 100% crash, I dunno what I should call it then. I clicked the textballoon icon myself. The soundbuffer kept repeating after an F8, I was able to save the project I think, but after that I had to close the whole thing and cubase ended a little bit non-reactive. Question is of course (since I wasn't doing rev instruments and since other than that you don't create any sound yourself) where the possible problem is.. Inside revisit? Inside Cubase? Inside Cubase, but caused by revisit?

Edited by CS_TBL 2008-09-02 9:07 AM
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-02 10:50 PM (#14357 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
Another crash/bufferhang. I don't mind testing things, but once my TV stuff will commence I can't have this, and I may have to go back to 0.91 which was reasonably stable..
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-03 12:07 AM (#14358 - in reply to #14357)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
And again, but this time during note-enter, so it's probably not exclusively related to pressing F8.
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2008-09-03 1:21 AM (#14359 - in reply to #14358)
Subject: Re: reViSiT v0.94 Beta released!



Developer

Posts: 746
50010010025
Location: England
Hmm, I'm not sure how reViSiT could cause soundbuffer problems, if it's not actually using the soundbuffer. Of course, if it's not reViSiT, then moving back to v0.91 won't solve your problems. It kind of sounds like a sound driver problem - have you rolled back to the configuration you had before our debug sessions? ASIO4ALL is a great piece of software, but can sometimes have problems. How frequent are the problems (in, for example, minutes or hours of use)?

If you're game, next time you have this problem; try messing about in reViSiT while Cubase is "sluggish". If reViSiT has become unstable (e.g. due to a memory leak) trying different things might provoke a crash, which would allow you to send me a crash report, so I can locate the problem (if one exists!).

If that doesn't work; on the next opportunity, you could also try gradually rolling back the project - remove VSTi's one at a time, and see if this provokes any crashes / error messages. Again, if a memory leak has occurred, this might provoke a crash as the VSTi tries to free corrupted/nonexistent memory.

Let me know if you notice any other trends in the problem that might indicate if it's related to something you're doing in reViSiT or not.

I might have noticed some problems with reViSiT not stopping playback properly, but I can't see how this would affect the soundbuffer, if you haven't used it. Mostly, it's just a nuisance when you want to load a file (as playback must be stopped), and can be worked-around by a press of Ctrl-I. Has anyone else encountered this one?

Chris
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-03 11:13 AM (#14360 - in reply to #14359)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
I'm using my (Terratec) Aureon driver (as I've always done). Just minutes ago it crashed again after having played back some song I was working on for less than 10 minutes.

This is what I could do:
- move around in revisit (cursor, menus)
- move around in cubase (unloading Halions close revisit window etc.)
- couldn't play any sound anymore, not from revisit, not from pressing Halion's own keyboard
- closing cubase was not really possible the conventional way, upon trying to close I got the not-responding type o' things.

I'll now try 0.91 with an older project, hold your breath.. :P
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-03 1:42 PM (#14361 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
Need to test a bit more, but my first impression is that 0.91 is stable.
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-03 10:37 PM (#14362 - in reply to #14361)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
Ok, scrap it, it just did the same in 0.91.

Funnily enough, it happens when I'm editing/tracking, when I just load a tune and play it a bit, it usually stays stable.

Edited by CS_TBL 2008-09-03 10:40 PM
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-03 11:54 PM (#14363 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
And again, after about 1 minute of playing after having loaded a project, after a clean boot.. *sigh*

Ok, I seriously am going to have a problem with all this.., and I don't know what to fix as I don't know how things got fubar in the first place..
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-04 1:34 AM (#14364 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
I'm beginning to think the bug is actually inside Halion, combined with a particular tune of mine..
Bookmark and Share Top of the page Bottom of the page
arnorhs
Posted 2008-09-07 4:29 PM (#14365 - in reply to #14335)
Subject: Re: reViSiT v0.94 Beta released!


Member

Posts: 10

Ahh ok, it had to be something...

Anyways, I sent two crash reports just now (easily reproducable) - both have to do with the same thing, namely, changing the output bus on track two (strangely, this only seems to affect some tracks and it's not random)

This was fine in revisit 9.2, but it broke in 9.3 and I hoped it was fixed in 9.4, but it's still the same way

best,
Arnor
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2008-09-07 5:46 PM (#14366 - in reply to #14365)
Subject: Re: reViSiT v0.94 Beta released!



Developer

Posts: 746
50010010025
Location: England
Thanks - got the reports, fixed the bug. It's limited to the PRO edition and was caused by not accounting for the extra "MIDI" button for MIDI triggered patterns.

New version coming presently, so long as my UPS can keep me up and running during the storm (about two dozen power cuts so far).

Cheers,
Chris
Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2008-09-07 7:19 PM (#14367 - in reply to #14352)
Subject: RE: reViSiT v0.94 Beta released!



Veteran

Posts: 102
100
Location: Austria
chrisnash - 2008-09-01 11:33 PM

Fegi:

Worrying that the MIDI doesn't work for you in REAPER. Can you check whether *non* "VST Host" (e.g. external) MIDI works in both sync'd or non-sync'd mode?



hi chris!

i was on vacation last week so i couldn't respond earlier...

when i set the output device for example to microsoft gs wavetable sw synth i can hear something...is that what you meant?
i wonder if someone else could confirm this...the break definately happened between pre 1 and pre 2 of v0.93.

btw: you know that you can always grab the fully functional evaluation version of reaper here, right?

greetings,

fegi
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2008-09-07 8:50 PM (#14368 - in reply to #14367)
Subject: RE: reViSiT v0.94 Beta released!



Developer

Posts: 746
50010010025
Location: England
Hi fegi,

Yeah, I have a copy of REAPER. I just circulated a new PRO version - see if it fixes your problem, and let me know.

Chris
Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2008-09-07 9:47 PM (#14369 - in reply to #14368)
Subject: RE: reViSiT v0.94 Beta released!



Veteran

Posts: 102
100
Location: Austria
everything seems to be working fine again. thanks chris i'll have a deeper look into it the next days...
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2008-09-22 12:26 PM (#14372 - in reply to #14369)
Subject: Re: reViSiT v0.94 Beta released!



Expert

Posts: 512
500
Location: Netherlands
How about this:

When clicking the rev window to activate it again after being deactivated due hopping to some plugin window, don't place the cursor at the mouseposition (nor start a block). Here should be a difference between mousedown and mouseenter (an event which happens only once, when entering a window).
Bookmark and Share Top of the page Bottom of the page
fegi
Posted 2008-10-08 3:08 PM (#14373 - in reply to #14335)
Subject: RE: reViSiT v0.94 Beta released!



Veteran

Posts: 102
100
Location: Austria
- on my system with 0.94.1 pro, channel and instrument colors are not saved between sessions. can anyone confirm?
- just a little nitpick, but i find it a bit annoying that when opening the order list f11, the cursor is not in the list itself now
Bookmark and Share Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)