Search | Statistics | User Listing Forums


Forums supporting
reViSiT (http://revisit.info)
and MIVI (http://mivi.nashnet.co.uk)
nashNET Forums ->  reViSiT - Tracking Software for VST hosts -> Testing & Development -> View Thread

You are logged in as a guest. ( logon | register )

reViSiT v1.3.2 Pro update available
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   reViSiT - Tracking Software for VST hosts -> Testing & DevelopmentMessage format
 
chrisnash
Posted 2010-02-02 8:19 PM (#15047)
Subject: reViSiT v1.3.2 Pro update available



Developer

Posts: 746
50010010025
Location: England

Hi everyone,

I'm pleased to present you with reViSiT 1.3.2 Pro, which includes a number of fixes and small tweaks, most notably towards improved external MIDI timing. There'd been elusive issues with this for some time now, but a flash of inspiration has allowed me to significantly increase the precision of live and recorded MIDI events sent to external drivers (e.g. LoopBe1, hardware interfaces). A number of other minor refinements are also included in this release (see below).

Download reViSiT v1.3.2 Pro from http://www.nashnet.co.uk/experiment/download.asp.
(not registered? Register for free, as part of the reViSiT Experiment)

Enjoy!
Chris

--------------------------------------------------------
v1.3.2
[MOD] Improved External MIDI timing precision.
[MOD] Clicking selections without dragging now deselects.
[MOD] New reViSiT logo on toolbar (links to website).
[FIX] MIDI Delay not working for External MIDI.
[FIX] Shift- not triggering hanging notes.
[FIX] Interpolate not working with maximum values.
[FIX] Drag outline extends one row too far.

Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-08 8:06 PM (#15053 - in reply to #15047)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
I have a problem, but I don't know what it is - yet.

After a while (minutes) LoopBe stops receiving anything that goes out from reViSiT via those LoopBe ports. Can you check whether there's any chance you've broken something there? :P
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-08 8:14 PM (#15054 - in reply to #15053)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
Demons found!

Your shut-up routine (a.k.a. F8) scares the feeble bits out of LoopBe. LoopBe doesn't report anything special though (so it's not a feedback loop or something).
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2010-02-08 9:25 PM (#15055 - in reply to #15054)
Subject: Re: reViSiT v1.3.2 Pro update available



Developer

Posts: 746
50010010025
Location: England
Are these two posts about the same issue?

It's possible Windows is running out of timers - the new timing mechanism solves some problems by using multiple timers, but the number is limited in Windows.
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-08 9:29 PM (#15056 - in reply to #15055)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
It was the same issue yes.

So.. the solution will be? :P
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2010-02-08 10:38 PM (#15057 - in reply to #15056)
Subject: Re: reViSiT v1.3.2 Pro update available



Developer

Posts: 746
50010010025
Location: England
I'll have to look at a way of reducing the number of timers, if I confirm it to be that. reViSiT uses one timer per audio buffer, but releases the timer as soon as all the scheduled MIDI events are dispatched. So, should that be where the problem is, you might be able to workaround it by increasing your ASIO buffer / latency.

Let me know if that makes any difference.

Best,
Chris
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-12 1:01 AM (#15058 - in reply to #15057)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
Quick, before the Mayan calendar runs out:

Run a velocity sensitive VSTi, input notes in the rev.Pattern, every so many notes the note auditioning velocity is lower than others.
Bookmark and Share Top of the page Bottom of the page
chrisnash
Posted 2010-02-12 4:08 PM (#15059 - in reply to #15058)
Subject: Re: reViSiT v1.3.2 Pro update available



Developer

Posts: 746
50010010025
Location: England
Maarten, I've looked into the velocity issue you mentioned, using MIDI monitor to see what velocities a VSTi is receiving and everything looks fine. The same velocity is maintained each time. Could it be something to do with how you're using MIDI channel volume?
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-12 4:24 PM (#15060 - in reply to #15059)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
Try inputting the same note all over again. Like a whole column o' C4's or so.
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-12 4:37 PM (#15061 - in reply to #15047)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
I've proof on video :D Will try to find a small videoformat in order to send it.
Bookmark and Share Top of the page Bottom of the page
CS_TBL
Posted 2010-02-12 5:00 PM (#15062 - in reply to #15061)
Subject: Re: reViSiT v1.3.2 Pro update available



Expert

Posts: 512
500
Location: Netherlands
A side note: I acquired a netbook today (practical for college). I'll prolly put part of my music shebang on it as well. While I don't expect much oddness in terms of revisit, I'll try to run things on it now and then.
Bookmark and Share Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)