Search Forums

Forums supporting
reViSiT (
and MIVI (
nashNET Forums ->  reViSiT - Tracking Software for VST hosts -> Help & Support -> View Thread

You are logged in as a guest. ( logon | register )

Midi recording problem in Reaper
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   reViSiT - Tracking Software for VST hosts -> Help & SupportMessage format
Posted 2013-03-28 4:38 AM (#15415)
Subject: Midi recording problem in Reaper


Posts: 12

Hi, I am suffering a weird problem when trying to record to midi what I compose in Revisit. At first it seems that record timing is out of sync, but looking closer it's because the first note is actually quite smaller than it should so the rest gets out of sync. You can see a couple of screenshots showing the result of a very simple 4 notes recording.

They are here:

The first one shows the recorded result. The second one shows the first note copy and pasted to notice the difference in length. And a third showing the same exact recording in Cubase which didn't show this kind of problem. Tried also the same in Fruity Loops and there is no problem too. I tried with very different versions of Revisit and same problem. I tried to play and change with the midi settings Reaper has but no luck. It seems to be something about Reaper itself. I searched here and in Reaper forums before posting here but didn't find anything about this. Does anyone else have this kind of problem or am I the only one ? Is there some kind of fix or solution someone know ? I decided to post this here first to see if there is already some kind of workaround about this and to have a response about it not being a problem of Revisit before posting it in the Reaper forums where I expect the typical "its a problem of xxxxx not Reaper" kind of response.

Thanks very much and sorry for the inconvenience.
Bookmark and Share Top of the page Bottom of the page
Posted 2013-03-28 9:11 AM (#15416 - in reply to #15415)
Subject: RE: Midi recording problem in Reaper


Posts: 746
Location: England
Hi Alandor,

As you say, it does look like REAPER is the cause, but there should be a workaround. However, I don't think it's the shortness of the first note that is dragging subsequent notes out of sync - but that everything is out of sync, and REAPER is truncating the first note because it goes out of bounds.

It might be that something is awry with the "plug-in delay compensation". As audio is processed in buffers, there's an inherent delay in the output, which needs to be added onto MIDI signals. This has to either be done by the host or by the plugin.

Try messing around with the MIDI Delay setting in reViSiT's settings (F12). The default is "Auto", but you can set it manually - as well as to 0. If you have no joy, then you might go hunting for related settings in REAPER - as well as enabling or disabling the plug-in delay compensation.

Let us know how you get on.

Bookmark and Share Top of the page Bottom of the page
Posted 2013-03-30 3:05 PM (#15417 - in reply to #15415)
Subject: Re: Midi recording problem in Reaper


Posts: 12

Hi again. I did all the tests using the MIDI delay option in reViSiT with no luck. You can manually delay all the midi recorded, but the first note will have the same shorter length than the rest so it will start after a little white space. I looked in the forums about PDC so I could disable it and discover there is a lot of problems and complains of people having VSTs that doesn't sync correctly. Apparently is not a bug of Reaper but that some VSTs generate latency where some others not (or something like that). So to overcome this problem you have to manually activate or deactivate the PDC for each one. At this time I thought this was clearly the problem. Sadly, this didn't worked either when applied to reViSiT. Very same exact behavior.

The great thing is that I discovered a way to totally overcome the problem using a different approach. The way I knew how to use reViSiT midi out was through the use of external virtual midi cables (such as Midi Yoke and loopMIDI for x64 support), as it is way easier and "standard" than learning how each host I test manages the internal vst host midi routing. In fact in Cubase 5 when I tried to use the vst host midi it worked but it was sending the output to all channels despite what channel I choose reViSiT to sent and which channel I choose in each track on Cubase to receive from. So back then I looked for solutions and discover the use of virtual midi cables which worked flawlessly. Thing is when I tried to test Reaper I found using the same exact setup didn't work as expected (as I posted in my first comment). So after learning about the PDC and thinking other ways to solve the issue I think, why if I learn if I can successfully use the internal vst host midi routing ? And tadaaaaaaaaaa, no issue. All work as it should. I can select the reViSiT plugin as a send to the other tracks (making sure to configure the route of each track to use the right midi channel for that track) select to record the output and record the midi output flawlessly. Another different thing that can be done is to assign to the reViSiT track midi output to a virtual midi cable like loopMIDI which will allow to use external software or devices to Reaper itself or use the loopMIDI as input for the tracks. If you record the this input it works too flawlessly.

So apparently the trouble is about using the virtual cable externally from reViSiT midi output to the input of the same midi cable. If it's Reaper which manages the routing of the cables they seem to work correctly.

I hope this can help to other people who is trying this kind of problem using Reaper. If you or anyone else need to know more information about this or something related, just ask.

Bookmark and Share Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)